trust level="medium"

Jul 15, 2010 at 10:06 AM

Nice to meet you, and MWPSK was variously examined, and it knew your EPS Cms.
Liberate from the restriction in the MWPSK layout, and thank you for wonderful CMS.
However, when the site is up-loaded to the rental server and it opens it to the public, the server error occurs, it is not possible to open to the public, and it descends.
Could you advise on the method of settlement?My best regards.
The server error occurred by''/application.
--------------------------------------------------------------------------------

Security exceptionExplanation:This application started executing the operation had not been permitted by the security policy. Please consult the system administrator to acquire a necessary access permit in this application or change the trust level of the application by the configuration file.
Details of exception: System.Security.SecurityException: It failed in the demand of the access permit of type 'System.Configuration.ConfigurationPermission, System.Configuration, Version=2.0.0.0, Culture=neutral, and PublicKeyToken=b03f5f7f11d50a3a'.

Source error:
The exception that the steering wheel was not done while executing a present Web demand was generated. Information on the cause of disability and the site of incidence can be confirmed by using the exception stack trace below.
Stack trace:

SecurityException: It failed in the demand of the access permit of type 'System.Configuration.ConfigurationPermission, System.Configuration, Version=2.0.0.0, Culture=neutral, and PublicKeyToken=b03f5f7f11d50a3a'.
System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) +0
System.Security.CodeAccessPermission.Demand() +58
System.Configuration.BaseConfigurationRecord.CheckPermissionAllowed(String configKey, Boolean requirePermission, Boolean isTrustedWithoutAptca) +99

--------------------------------------------------------------------------------
 

Oct 8, 2010 at 6:13 AM

Hi Rickard. Resolved

Recommendation was Error.log. Error was eliminated after i add a 'requirePermission = "false" ' sectiongroup rewrite of the Web.config. 

<sectionGroup name="rewrite">
<section name="sections" requirePermission="false" type="System.Configuration.NameValueSectionHandler,System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089,Custom=null"/>
</sectionGroup>